AnsweredAssumed Answered

Windows Cloud Agent - failed to start service after reboot

Question asked by Frank Diag on Feb 14, 2019
Latest reply on Feb 7, 2020 by Tim Boothby



New user of Qualys here.  I recently deployed the Cloud Agent to ~100 Windows and Linux servers.   


I ran Windows Update on 3 servers today and after rebooting the Cloud Agent failed to start on 2 out of the 3 servers. 

Same error on each:  Event ID 7000 and 7009 (timeout after 30000 milliseconds, service did not respond in timely manner).   I had to manually start the Cloud Agent service.


I checked the Log.txt for each server, and in both I saw the same thing.  The agent would initialize and be assigned a PID, then it would sit there and do nothing...until I manually start it and it gets assigned a new PID.  Here's an excerpt that shows the agent exiting upon server reboot, then starting up at 13:45:39 getting PID 4968 (this was the server coming up) and then starting up again at 13:53:10 getting PID 3348 (this is when I manually started it because it failed to start the first time).


02/14/2019 13:34:46.0565 [10F8]"1i0": Information: Scheduling Thread: EXITING...
02/14/2019 13:34:54.0006 [1250]"3cs": Information: Qualys Agent exited. ProcessId: 5064

02/14/2019 13:45:39.0832 [FD8]"1p7": None: Setting trace level from "Verbose" to "Verbose".
02/14/2019 13:45:39.0879 [FD8]"1gv": Information: QualysAgent.exe initializing. ProcessId: 4968
02/14/2019 13:53:10.0194 [D04]"1p7": None: Setting trace level from "Verbose" to "Verbose".
02/14/2019 13:53:10.0194 [D04]"1gv": Information: QualysAgent.exe initializing. ProcessId: 3348
02/14/2019 13:53:10.0272 [D04]"1p7": None: Setting trace level from "Verbose" to "Verbose".
02/14/2019 13:53:10.0303 [FDC]"1h4": Information: Qualys Agent service starting up.
02/14/2019 13:53:10.0303 [10B0]"1hk": Information: Scheduling thread started...
02/14/2019 13:53:10.0396 [10B0]"1jx": Information: CPU Throttling Enabled - set to 20%
02/14/2019 13:53:10.0459 [438]"291": System: Throttling thread id: [438], throttling percentage: 20%
02/14/2019 13:53:10.0459 [10B0]"1eo": Information: CONTROL_EVENT_CAPI is deferred to run in 0 seconds.
02/14/2019 13:53:10.0459 [10B0]"1eo": Information: CONTROL_EVENT_SCAN is deferred to run in 5949 seconds.


Server1 is running Windows 2008 R2 Standard and Server2 is running Windows 2008 R2 Enterprise.


Anybody run into this?  I'm wondering if I'm going to be seeing this happen on more of my servers.