AnsweredAssumed Answered

Code 1980: record limit exceeded

Question asked by Nicholas DeSantis on Dec 10, 2018
Latest reply on Dec 11, 2018 by Jeff Leggett

I have a python script using the requests module to list all of my assets based off of a tag set. When I make the API call, I get the following warning: 


<TEXT>1000 record limit exceeded. Use URL to get next batch of results.</TEXT>


This is not feasible for me. Is there a parameter I can use in my payload to override this? It gives me a second URL to use, but this needs to be automated without any manual intervention. 


This is the current URL I am using and the payload:


payload = {'action':'list', 'use_tags':'1', 'tag_set_include':'XXXXX'}


Is there a parameter to add to override the limit. I don't see anything in the parameter list:

(action=list allows: echo_request, ips, ids, id_min, id_max, details, queued_for_purge, ag_ids, ag_titles, os_pattern, network_ids, truncation_limit, show_tags, use_tags, tag_set_by, tag_include_selector, tag_exclude_selector, tag_set_include, tag_set_exclude, compliance_enabled, no_compliance_scan_since, compliance_scan_since, no_vm_scan_since, vm_scan_since, vm_processed_after, vm_processed_before, vm_scan_date_before, vm_scan_date_after, vm_auth_scan_date_before, vm_auth_scan_date_after)

Any help is appreciated.